2012年3月30日

Final Cut Express 4をインストールするとAperture 3が起動しない件

このエントリーをブックマークに追加 このエントリーを含むはてなブックマーク
久々にMacBook Proで動画編集でもしようかとFinal Cut Express 4をインストールしてみたら、直後からAperture 3が起動不能に。
日本のAppleサポートコミュニティはおろか米国のAppleサポートコミュニティにも対応策が無いという状態。

エラーの発生環境はMac OS X Lion (10.7.3)で、別ユーザを作成しての確認、Apertureの再インストールでは治らず。
という訳で、エラーを解析してみる。

Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

とあるので、おそらく原因はPluginManagerというファイルが存在しないことだろう。
Versionsフォルダへ移動してみると、フォルダ「B」が存在しない。
現在Aperture 3が普通に起動できるMacBook AirのVersionsフォルダを覗くとフォルダBと、その中にPluginManagerが存在していた。
これをMacBook Proにコピーすると、何事も無かったのようにAperture 3が起動。

とりあえず、PluginManagerを置いておきますので、同様のエラーで困ってる人はやってみてください。

Download >> PluginManager.zip (115KB)

1 件のコメント:

  1. 「B」フォルダも「PluginManager」も存在していましたが、「PluginManager」を上書きコピーすると起動することができました。
    手元の「PluginManager」のタイムスタンプは2008/2/27のものでしたので、どこかで古い物に置き換わっていたようです。
    助かりました。

    返信削除

Recent Photos from Atelier (Flickr)

作業場で撮影した写真をアップロードしています。記事にする前の試作なども公開中です。